188宝金博
你的位置:188bet体育_188宝金博官网 > 188bet体育产品中心 > 188宝金博 清爽信中线掘金术选股目的公式源码编程思绪破译及到手率回测数据

188宝金博 清爽信中线掘金术选股目的公式源码编程思绪破译及到手率回测数据

时间:2022-08-30 12:36 点击:121 次

编程思绪破译:188宝金博

N赋值:5

VAR1赋值:收盘价>1日前的收盘价 AND 收盘价>2日前的收盘价

VAR2赋值:1日前的VAR1 AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价

VAR3赋值:1日前的VAR2 AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价

VAR4赋值:1日前的VAR3 AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价

VAR5赋值:1日前的VAR4 AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价

VAR6赋值:1日前的VAR5 AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价

VAR7赋值:1日前的VAR6 AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价

VAR8赋值:1日前的VAR7 AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价

VAR9赋值:1日前的VAR8 AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价

VARA赋值:1日前的VAR9 AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价

VARB赋值:1日前的VARA AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价

VARC赋值:1日前的VARB AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价

VARD赋值:收盘价<1日前的收盘价 AND 收盘价<2日前的收盘价

VARE赋值:1日前的VARD AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价

VARF赋值:1日前的VARE AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价

VAR10赋值:1日前的VARF AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价

VAR11赋值:1日前的VAR10 AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价

VAR12赋值:1日前的VAR11 AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价

VAR13赋值:1日前的VAR12 AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价

VAR14赋值:1日前的VAR13 AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价

VAR15赋值:1日前的VAR14 AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价

VAR16赋值:1日前的VAR15 AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价

VAR17赋值:1日前的VAR16 AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价

VAR18赋值:1日前的VAR17 AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价

VAR19赋值:1日前的VARDORVAREORVARFORVAR10ORVAR11ORVAR12ORVAR13ORVAR14ORVAR15ORVAR16ORVAR17ORVAR18 AND VAR1

赋值: (最高价 + 最廉价 + 收盘价)/3

CC1赋值:(TYP-TYP的14日简短迁徙平均)/(0.015*TYP的14日平均竣工偏差)

C1赋值:CC1的3日[1日权重]迁徙平均

C2赋值:C1的3日[1日权重]迁徙平均

C3赋值:3*C1-2*C2

CB1赋值:C3的5日指数迁徙平均

CB2赋值:1日前的CB1

赋值: 1日前的收盘价

RSI1赋值:收盘价-LC和0的较大值的6日[1日权重]迁徙平均/收盘价-LC的竣工值的6日[1日权重]迁徙平均*100

RSI赋值:(RSI1-50)*5

R1赋值:RSI的3日[1日权重]迁徙平均

D1赋值:R1的3日[1日权重]迁徙平均

J1赋值:3*R1-2*D1

RR1赋值:J1的5日指数迁徙平均

RR2赋值:1日前的RR1

RR赋值:RR1>RR2

RSV赋值:(收盘价-9日内最廉价的最低值)/(9日内最高价的最高值-9日内最廉价的最低值)*100

K赋值:RSV的3日[1日权重]迁徙平均

K1赋值:(K-50)*5

K2赋值:K1的3日[1日权重]迁徙平均

D2赋值:K2的3日[1日权重]迁徙平均

J2赋值:3*K2-2*D2

BB1赋值:J2的5日指数迁徙平均

BB2赋值:1日前的BB1

输出中线掘金术:RR AND 取反 AND (RR1<-100 AND BB1<-100) AND CB1<-100 AND VAR19=1

条款选股:清爽信中线掘金术[日线]到手率测试

测试股票数:4996

共发出信号:164856 到手信号:65706 失败信号:98424 未完成信号:726

信号发出率:92.97% 平均到手率:40.03% 到手率达到50%的股票数有:27.75%

利润1总平均:11.97% 最大平均利润1:  149.66%  最小平均利润1:  0.00%

利润2总平均:0.86% 最大平均利润2: 140.63%  最小平均利润2:  -42.40%

动作源码:

N:=5;

VAR1:=CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);

VAR2:=REF(VAR1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

VAR3:=REF(VAR2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

VAR4:=REF(VAR3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

VAR5:=REF(VAR4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

VAR6:=REF(VAR5,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

VAR7:=REF(VAR6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

VAR8:=REF(VAR7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

VAR9:=REF(VAR8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

VARA:=REF(VAR9,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

VARB:=REF(VARA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

VARC:=REF(VARB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

VARD:=CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2);

VARE:=REF(VARD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

VARF:=REF(VARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

VAR10:=REF(VARF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

VAR11:=REF(VAR10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

VAR12:=REF(VAR11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

VAR13:=REF(VAR12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

VAR14:=REF(VAR13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

VAR15:=REF(VAR14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

VAR16:=REF(VAR15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

VAR17:=REF(VAR16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

VAR18:=REF(VAR17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

VAR19:=REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR

VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,1) AND VAR1;

TYP := (HIGH + LOW + CLOSE)/3;

CC1:=(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14));

C1:=SMA(CC1,3,1);

C2:=SMA(C1,3,1);

C3:=3*C1-2*C2;

CB1:=EMA(C3,5);

CB2:=REF(CB1,1);

LC := REF(CLOSE,1);

RSI1:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;

RSI:=(RSI1-50)*5;

R1:=SMA(RSI,3,1);

D1:=SMA(R1,3,1);

J1:=3*R1-2*D1;

RR1:=EMA(J1,5);

RR2:=REF(RR1,1);

RR:=RR1>RR2;

RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;

K:=SMA(RSV,3,1);

K1:=(K-50)*5;

K2:=SMA(K1,3,1);

D2:=SMA(K2,3,1);

J2:=3*K2-2*D2;

BB1:=EMA(J2,5);

BB2:=REF(BB1,1);

中线掘金术:RR AND NOT(REF(RR188宝金博,1)) AND (RR1<-100 AND BB1<-100) AND CB1<-100 AND VAR19=1;

本站是提供个人常识责罚的网罗存储空间,系数现实均由用户发布,不代表本站主张。请防护甄别现实中的关系格式、教导购买等信息,预防诈欺。如发现存害或侵权现实,请点击一键举报。
回到顶部
服务热线
官方网站:www.365jz.com
工作时间:周一至周六(09:00-18:00)
联系我们
QQ:2852320325
邮箱:w365jzcom@qq.com
地址:武汉东湖新技术开发区光谷大道国际企业中心
关注公众号

Powered by 188bet体育_188宝金博官网 RSS地图 HTML地图

188bet体育
188bet体育_188宝金博官网-188宝金博 清爽信中线掘金术选股目的公式源码编程思绪破译及到手率回测数据